BETA

20th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [20/02/18 11:18 AM] with 'Major Outage'

Issue has been resolved at [20/02/18 11:19 AM]