BETA

20th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [20/02/18 09:19 AM] with 'Partial Outage'

Issue has been resolved at [20/02/18 09:20 AM]