BETA

20th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [20/02/18 07:33 AM] with 'Major Outage'

Issue has been resolved at [20/02/18 07:34 AM]