BETA

20th February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [20/02/18 02:18 AM] with 'Major Outage'

Issue has been resolved at [20/02/18 02:19 AM]