BETA

19th February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [19/02/18 09:39 PM] with 'Major Outage'

Issue has been resolved at [19/02/18 09:40 PM]