BETA

19th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [19/02/18 07:48 PM] with 'Partial Outage'

Issue has been resolved at [19/02/18 07:49 PM]