BETA

19th February 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [19/02/18 07:34 PM] with 'Major Outage'

Issue has been resolved at [19/02/18 07:37 PM]