BETA

19th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [19/02/18 07:20 PM] with 'Partial Outage'

Issue has been resolved at [19/02/18 07:22 PM]