BETA

19th February 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [19/02/18 11:52 AM] with 'Major Outage'

Issue has been resolved at [19/02/18 11:56 AM]