BETA

16th February 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [16/02/18 12:03 PM] with 'Major Outage'

Issue has been resolved at [16/02/18 12:09 PM]