BETA

15th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/02/18 05:19 PM] with 'Partial Outage'

Issue has been resolved at [15/02/18 05:20 PM]