BETA

14th February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/02/18 08:29 PM] with 'Major Outage'

Issue has been resolved at [14/02/18 08:31 PM]