BETA

14th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/02/18 06:09 PM] with 'Major Outage'

Issue has been resolved at [14/02/18 06:10 PM]