BETA

23rd June 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [23/06/16 12:27 PM] with 'Partial Outage'

Issue has been resolved at [23/06/16 12:31 PM]