BETA

14th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/02/18 05:02 PM] with 'Major Outage'

Issue has been resolved at [14/02/18 05:03 PM]