BETA

14th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/02/18 05:01 PM] with 'Major Outage'

Issue has been resolved at [14/02/18 05:03 PM]