BETA

13th February 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [13/02/18 07:23 AM] with 'Partial Outage'

Issue has been resolved at [13/02/18 07:24 AM]