BETA

13th February 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/02/18 02:30 AM] with 'Major Outage'

Issue has been resolved at [13/02/18 02:32 AM]