BETA

12th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/02/18 02:13 PM] with 'Major Outage'

Issue has been resolved at [12/02/18 02:14 PM]