BETA

11th February 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [11/02/18 01:00 AM] with 'Major Outage'

Issue has been resolved at [11/02/18 01:02 AM]