BETA

10th February 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/02/18 01:05 PM] with 'Major Outage'

Issue has been resolved at [10/02/18 01:07 PM]