BETA

26th March 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [26/03/17 04:18 AM] with 'Major Outage'

Issue has been resolved at [26/03/17 05:43 AM]