BETA

10th February 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/02/18 12:46 PM] with 'Major Outage'

Issue has been resolved at [10/02/18 12:47 PM]