BETA

10th February 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/02/18 12:21 PM] with 'Partial Outage'

Issue has been resolved at [10/02/18 12:22 PM]