BETA

10th February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/02/18 12:21 PM] with 'Major Outage'

Issue has been resolved at [10/02/18 12:22 PM]