BETA

2nd February 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/02/18 05:30 AM] with 'Partial Outage'

Issue has been resolved at [02/02/18 05:31 AM]