BETA

30th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/01/18 11:42 AM] with 'Major Outage'

Issue has been resolved at [30/01/18 11:43 AM]