BETA

28th January 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [28/01/18 10:58 PM] with 'Partial Outage'

Issue has been resolved at [28/01/18 11:01 PM]