BETA

26th January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [26/01/18 01:43 PM] with 'Partial Outage'

Issue has been resolved at [26/01/18 01:45 PM]