BETA

25th January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [25/01/18 01:47 AM] with 'Partial Outage'

Issue has been resolved at [25/01/18 01:48 AM]