BETA

24th January 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [24/01/18 03:50 PM] with 'Partial Outage'

Issue has been resolved at [24/01/18 03:51 PM]