BETA

24th January 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [24/01/18 11:10 AM] with 'Major Outage'

Issue has been resolved at [24/01/18 11:11 AM]