BETA

23rd January 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/01/18 01:49 PM] with 'Partial Outage'

Issue has been resolved at [23/01/18 01:50 PM]