BETA

23rd January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [23/01/18 01:11 PM] with 'Major Outage'

Issue has been resolved at [23/01/18 01:12 PM]