BETA

23rd January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [23/01/18 01:34 AM] with 'Partial Outage'

Issue has been resolved at [23/01/18 01:41 AM]