BETA

22nd January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [22/01/18 10:29 AM] with 'Partial Outage'

Issue has been resolved at [22/01/18 10:30 AM]