BETA

22nd January 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [22/01/18 10:28 AM] with 'Major Outage'

Issue has been resolved at [22/01/18 10:29 AM]