BETA

22nd January 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [22/01/18 10:23 AM] with 'Major Outage'

Issue has been resolved at [22/01/18 10:24 AM]