BETA

22nd January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/01/18 10:22 AM] with 'Major Outage'

Issue has been resolved at [22/01/18 10:23 AM]