BETA

21st January 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [21/01/18 02:28 PM] with 'Major Outage'

Issue has been resolved at [21/01/18 02:29 PM]