BETA

21st January 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [21/01/18 02:26 PM] with 'Partial Outage'

Issue has been resolved at [21/01/18 02:28 PM]