BETA

20th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [20/01/18 09:30 PM] with 'Major Outage'

Issue has been resolved at [20/01/18 09:31 PM]