BETA

15th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/01/18 08:07 PM] with 'Major Outage'

Issue has been resolved at [15/01/18 08:08 PM]