BETA

14th January 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/01/18 08:44 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 08:45 PM]