BETA

14th January 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/01/18 07:44 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 07:47 PM]