BETA

22nd March 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [22/03/17 10:27 AM] with 'Partial Outage'

Issue has been resolved at [22/03/17 11:58 AM]