BETA

14th January 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/01/18 06:40 PM] with 'Partial Outage'

Issue has been resolved at [14/01/18 06:41 PM]