BETA

22nd March 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [22/03/17 06:39 AM] with 'Major Outage'

Issue has been resolved at [22/03/17 07:28 AM]