BETA

14th January 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/01/18 05:01 PM] with 'Major Outage'

Issue has been resolved at [14/01/18 05:02 PM]