BETA

22nd March 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [22/03/17 06:38 AM] with 'Major Outage'

Issue has been resolved at [22/03/17 07:04 AM]